# AccessDeniedException with docker + slurm on AWS

**URL:** https://community.seqera.io/t/accessdeniedexception-with-docker-slurm-on-aws/1287
**Category:** Ask for help
**Tags:** slurm, nextflow, aws
**Created:** [October 14, 2024, 2:23pm UTC](https://community.seqera.io/t/accessdeniedexception-with-docker-slurm-on-aws/1287 "2024-10-14T14:23:15Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Nick\_Riddiford](https://dub1.discourse-cdn.com/flex013/user_avatar/community.seqera.io/nick_riddiford/32/1134_2.png) [@Nick\_Riddiford](https://community.seqera.io/u/Nick_Riddiford)
#### Post date: [October 14, 2024, 2:23pm UTC](https://community.seqera.io/t/accessdeniedexception-with-docker-slurm-on-aws/1287/1 "2024-10-14T14:23:15Z")

</div>

Hi all,  
I’m running the `nf-core/rnaseq` pipeline on AWS using `-profile docker` and running with a config specifying `executor = 'slurm'`.

I have had trouble with permission at various steps of the pipeline (mostly `SALMON_QUANT` & `STAR_ALIGN` ) and I’ve tried various different combinations of docker params in the config that I’m using.

The error I see now comes from `NFCORE_RNASEQ:RNASEQ:ALIGN_STAR:STAR_ALIGN`:

```auto
Caused by:
  /path/to/nf-work-dir/work/b3/48b4e8.../sampleID._STARpass1
java.nio.file.AccessDeniedException: /path/to/nf-work-dir/work/b3/48b4e8.../sampleID._STARpass1

```

The docker section of my config looks like this:

```auto
docker {
    docker.enabled = true
    runOptions = "--user root -v /var/run/docker.sock:/var/run/docker.sock"
    docker.mountFlags = 'shared'
}

```

I’ve seen a few other posts here and elsewhere that touch on this, but I haven’t managed to find a solution that works for me.

Would love any advice or suggestions on how we can get this running!

Thanks in advance,

Nick

---

<div class="post-metadata">

### Author: ![mribeirodantas](https://dub1.discourse-cdn.com/flex013/user_avatar/community.seqera.io/mribeirodantas/32/235_2.png) [@mribeirodantas](https://community.seqera.io/u/mribeirodantas)
#### Post date: [November 15, 2024, 12:34am UTC](https://community.seqera.io/t/accessdeniedexception-with-docker-slurm-on-aws/1287/2 "2024-11-15T00:34:09Z")

</div>

Hi @Nick_Riddiford.

Can you share more detail about your AWS setup?

It’s not clear to me why you’d have permission issues with nf-core/rnaseq.
