# Nextflow Error

**URL:** <https://community.seqera.io/t/nextflow-error/835>\
**Category:** Ask for help\
**Tags:** nextflow, nf-core, google-cloud, platform\
**Created:** [June 10, 2024, 7:48pm UTC](https://community.seqera.io/t/nextflow-error/835 "2024-06-10T19:48:36Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![allisongrossberg](https://dub1.discourse-cdn.com/flex013/user_avatar/community.seqera.io/allisongrossberg/32/745_2.png) [@allisongrossberg](https://community.seqera.io/u/allisongrossberg)\
**Post date:** [June 10, 2024, 7:48pm UTC](https://community.seqera.io/t/nextflow-error/835/1 "2024-06-10T19:48:36Z")

</div>

I am trying to run the nf-core/smrnaseq workflow on Seqera cloud with Google Batch. My files are all in GCP buckets which have been connected to Seqera cloud with a credential. Whenever I try to run the workflow, all of the initial processes submitted fail with a mysterious error:

```txt
Process terminated for an unknown reason -- Likely it has been terminated by the external system.

```

I have increased the Quotas on my GCP account to have enough memory and CPUs, and the Batch jobs are being submitted and attempted, but failing while generating no logs and no exit code.

Any guidance on how to resolve this issue would be greatly appreciated.

---

<div class="post-metadata">

**Author:** ![mribeirodantas](https://dub1.discourse-cdn.com/flex013/user_avatar/community.seqera.io/mribeirodantas/32/235_2.png) [@mribeirodantas](https://community.seqera.io/u/mribeirodantas)\
**Post date:** [June 11, 2024, 12:11am UTC](https://community.seqera.io/t/nextflow-error/835/2 "2024-06-11T00:11:47Z")

</div>

Can you run a simple pipeline such as `nextflow-io/hello` in this compute environment? The first step in debugging is to make sure it’s not something in the CE (roles, etc).

---

<div class="post-metadata">

**Author:** ![allisongrossberg](https://dub1.discourse-cdn.com/flex013/user_avatar/community.seqera.io/allisongrossberg/32/745_2.png) [@allisongrossberg](https://community.seqera.io/u/allisongrossberg)\
**Post date:** [June 12, 2024, 2:39am UTC](https://community.seqera.io/t/nextflow-error/835/3 "2024-06-12T02:39:57Z")

</div>

Thank you for your response!

I have been able to run nextflow-io/hello and nf-core/smrnaseq with the test profile. As far as I can tell, the main difference is that the test files (10s of MB each) are much smaller than my sample files (~3 GB each).

I don’t think it is a problem with roles or permissions, and I am no longer getting errors saying that my CPU and/or memory quotas are being exceeded.

---

<div class="post-metadata">

**Author:** ![Adam\_Talbot](https://dub1.discourse-cdn.com/flex013/user_avatar/community.seqera.io/adam_talbot/32/62_2.png) [@Adam\_Talbot](https://community.seqera.io/u/Adam_Talbot)\
**Post date:** [June 18, 2024, 10:58am UTC](https://community.seqera.io/t/nextflow-error/835/4 "2024-06-18T10:58:01Z")

</div>

Sometimes [nf-schema](https://nextflow-io.github.io/nf-schema/latest/) gets a bit trigger happy and kills your pipeline before it can report what went wrong. When this happens I normally run the pipeline locally and try to recreate the error on my machine so I can check the logs, normally it means one of the parameters failed validation. Could you try running the same script with the command line and seeing if the pipeline starts? You can cancel it before it actually runs to prevent it running on your laptop.

---

<div class="post-metadata">

**Author:** ![ewels](https://dub1.discourse-cdn.com/flex013/user_avatar/community.seqera.io/ewels/32/1_2.png) [@ewels](https://community.seqera.io/u/ewels)\
**Post date:** [June 18, 2024, 12:06pm UTC](https://community.seqera.io/t/nextflow-error/835/5 "2024-06-18T12:06:15Z")

</div>

I don’t think it should be parameter validation, as that would happen on the Nextflow head job. Here it’s the process tasks that are being terminated, not the head job.

Is it possible to view the job submissions in GCP and get any additional information?

---

<div class="post-metadata">

**Author:** ![allisongrossberg](https://dub1.discourse-cdn.com/flex013/user_avatar/community.seqera.io/allisongrossberg/32/745_2.png) [@allisongrossberg](https://community.seqera.io/u/allisongrossberg)\
**Post date:** [July 1, 2024, 3:44pm UTC](https://community.seqera.io/t/nextflow-error/835/6 "2024-07-01T15:44:16Z")

</div>

Thank you for the responses, everyone. I looked into the logs and each of the child jobs in Batch has the following error/log message:

```auto
no VM has agent reporting correctly within the time window 1080 seconds. VM state for instance nf-686847ef-171798-2b22770e-de53-44a10-group0-0-hnff is 2024/06/10-02:05:36+0000,agent,start.

```

From what I have found [online](https://e.mail3.warbyparker.com/c/eJyEkjmXokoARn9NmdGnNqgiMMBB1HFpFFu7STi1sQlKAw0tv_6decsEL5n4fjf6rp7bUqaQz8wcMUQZZY4NZ_ncQVK5OEVc2SlUyBEuoQoJW0hFkY34rJhjiCm0IUGUMuS-KKEpoZhKyB2kKQIU1qKoyMsoWvlsRHsz7Yt61LNqnvd90wHiARwAHFTF_db9fwVwIAAOVFWoGyBB0gPi2wpT7QpX2KmmWtoiJUxTyYQkSBFuAHaSGhCfKi0INcqlyKEwRS41BEPFqYGSISR-7Qwgfj5en8xyLcHQIXAXKnPVqX4syHS0Vkl48Zb7dIjiTajThCQs98_OBcbDIsxXOuMyihZKPz9uYljFPx_mXTl-vztbqooxjZptmTTbA2O1CHYH6ewvweuloAe_XY-3N34751Yf6rIjl8zocs8-9ss3Hi6WOjPBV5Gtkk9ihU5S-VFZeo-d_Tb1X9MRte_ngOBg3ZxPuw06TetsS-Xn-fse-uMCXvvydL5OeTiuN8f1qmmDbFxm2uN3sdFkUSv8o72ertldhFRa8Wl45FCup-DrFvnysywsI-nVWZUfE4Kdwjvr8brab6LRt161He9O797-3ePko_SSx9Esj3l0izZ7NQ7T1mt-LkOz1Xa6Uj1pN8F0HOLDd1fsjC_useZtIpurCY7b0Xt7dZsTWpbxrDa90KIXc8AWAOPadJ3IzEYDjP-uA __5SQzwD4Bxb-qmEv1vF3HuEOz8A5v2URrV_8c4tP8FStSNKLL7b4vYDnU5YP6snd8_MfuuHdYNgMKmLQbRm9ZU4vkimqYyhf6V6V8BAAD__ 27eAMk), it appears to be an issue with the configuration of my Batch permissions or networking. I am going to try to resolve the issue following the advice in the linked page, but if anyone has experienced this issue and has further advice I would greatly appreciate it!
