# Nextflow not communicating back to Seqera

**URL:** <https://community.seqera.io/t/nextflow-not-communicating-back-to-seqera/2353>\
**Category:** Ask for help\
**Created:** [September 2, 2025, 4:18pm UTC](https://community.seqera.io/t/nextflow-not-communicating-back-to-seqera/2353 "2025-09-02T16:18:57Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![joshamilton](https://dub1.discourse-cdn.com/flex013/user_avatar/community.seqera.io/joshamilton/32/1309_2.png) [@joshamilton](https://community.seqera.io/u/joshamilton)\
**Post date:** [September 2, 2025, 4:18pm UTC](https://community.seqera.io/t/nextflow-not-communicating-back-to-seqera/2353/1 "2025-09-02T16:18:57Z")

</div>

I am experiencing a communication issue between Nextflow and Seqera on a custom pipeline running on AWS Batch. I can submit the run via Seqera Launchpad, and the job runs successfully on AWS Batch. Seqera captures the Nextflow execution log, which reports “Pipeline completed successfully". However, Seqera does not perform any real-time monitoring of Tasks, and reports that the “Workflow execution completed unsuccessfully.”

The Seqera execution log does produce this warning:

`WARN: Unable to serialize key=workflow.manifest; value=nextflow.config.Manifest@3333b099; type=nextflow.config.Manifest -- Cause: Cannot invoke "java.util.Collection.stream()" because "`

And the Nextflow log reports this error:

```auto
Sep-02 01:52:44.827 [main] DEBUG io.seqera.tower.plugin.TowerClient - Unexpected HTTP response
- endpoint : https://api.cloud.seqera.io/trace/421L6OnqZrcho3/begin?workspaceId=12346012330283
- status code : 400
- response msg: {“message”:“Unexpected error while processing request - Error ID: 4ld9ZgPvBjPlhX5kCfz09T”}
Sep-02 01:52:44.829 [main] DEBUG nextflow.Session - Unexpected error while processing request - Error ID: 4ld9ZgPvBjPlhX5kCfz09Tnextflow.exception.AbortOperationException: Unexpected error while processing request - Error ID: 4ld9ZgPvBjPlhX5kCfz09Tat io.seqera.tower.plugin.TowerClient.onFlowBegin(TowerClient.groovy:371)at nextflow.Session$_notifyFlowBegin_lambda38.doCall(Session.groovy:1088)at nextflow.Session.notifyEvent(Session.groovy:1138)at nextflow.Session.notifyFlowBegin(Session.groovy:1088)at nextflow.Session.fireDataflowNetwork(Session.groovy:530)at nextflow.script.ScriptRunner.run(ScriptRunner.groovy:250)at nextflow.script.ScriptRunner.execute(ScriptRunner.groovy:139)at nextflow.cli.CmdRun.run(CmdRun.groovy:379)at nextflow.cli.Launcher.run(Launcher.groovy:513)at nextflow.cli.Launcher.main(Launcher.groovy:673)

```

and

`Sep-02 02:51:45.233 [main] DEBUG nextflow.Session - Cannot invoke “java.lang.Thread.join()” because “this.sender” is null`  
`java.lang.NullPointerException: Cannot invoke “java.lang.Thread.join()” because “this.sender” is null`  
`at io.seqera.tower.plugin.TowerClient.onFlowComplete(TowerClient.groovy:403)`  
`at nextflow.Session$_notifyFlowComplete_lambda45.doCall(Session.groovy:1107)`  
`at nextflow.Session.notifyEvent(Session.groovy:1138)`  
`at nextflow.Session.notifyFlowComplete(Session.groovy:1107)`  
`at nextflow.Session.shutdown0(Session.groovy:768)`  
`at nextflow.Session.destroy(Session.groovy:713)`  
`at nextflow.script.ScriptRunner.shutdown(ScriptRunner.groovy:263)`  
`at nextflow.script.ScriptRunner.execute(ScriptRunner.groovy:147)`  
`at nextflow.cli.CmdRun.run(CmdRun.groovy:379)`  
`at nextflow.cli.Launcher.run(Launcher.groovy:513)`  
`at nextflow.cli.Launcher.main(Launcher.groovy:673)`

Complete logs are attached.

[seqera-421L6OnqZrcho3.log](https://community.seqera.io/uploads/short-url/bLcrr04MVwSq1wQLkwPugTSAz3.log) (5.5 KB)

[nf-421L6OnqZrcho3.txt](https://community.seqera.io/uploads/short-url/fIdiU62QMiwPQMRyu0kLDei2UDi.txt) (5.7 KB)

[nf-421L6OnqZrcho3.log](https://community.seqera.io/uploads/short-url/bRUlZgvDrA0nmUDAsaGDU1VImLw.log) (84.2 KB)

All of my other pipelines work correctly, so I don’t think it’s a problem with workspace credentials.

---

<div class="post-metadata">

**Author:** ![joshamilton](https://dub1.discourse-cdn.com/flex013/user_avatar/community.seqera.io/joshamilton/32/1309_2.png) [@joshamilton](https://community.seqera.io/u/joshamilton)\
**Post date:** [September 3, 2025, 4:35pm UTC](https://community.seqera.io/t/nextflow-not-communicating-back-to-seqera/2353/2 "2025-09-03T16:35:50Z")

</div>

Was able to resolve this myself. The issue was with the contributors block in the manifest section of nextflow.config:

```auto
manifest {
    contributors = [
        [
            name: 'Josh Hamilton'
        ]
    ]
}

```

Removing this block fixed the issue.

---

<div class="post-metadata">

**Author:** ![robsyme](https://dub1.discourse-cdn.com/flex013/user_avatar/community.seqera.io/robsyme/32/342_2.png) [@robsyme](https://community.seqera.io/u/robsyme)\
**Post date:** [September 5, 2025, 1:36am UTC](https://community.seqera.io/t/nextflow-not-communicating-back-to-seqera/2353/3 "2025-09-05T01:36:23Z")

</div>

Hi Josh

Thanks for the bug report. I had a closer look, and I see now that Nextflow _requires_ that each contributor has a “contribution” type (‘author’, ‘maintainer’, or ‘contributor’). This is an unintentional hard requirement, and should be a quick fix.

I’ve written up the bug report here: [Cannot parse manifest.contributors without contribution field. · Issue #6382 · nextflow-io/nextflow · GitHub](https://github.com/nextflow-io/nextflow/issues/6382)

I think this can be fixed in a couple of lines, so I’ll try to get the change merged asap.

In the meantime, can you test to see if this configuration works:

```groovy
manifest {
    contributors = [
        [
            name: 'Josh Hamilton',
            contribution: ['author']
        ]
    ]
}

```

---

<div class="post-metadata">

**Author:** ![system](https://dub1.discourse-cdn.com/flex013/user_avatar/community.seqera.io/system/32/2402_2.png) [@system](https://community.seqera.io/u/system)\
**Post date:** [September 12, 2025, 1:36am UTC](https://community.seqera.io/t/nextflow-not-communicating-back-to-seqera/2353/4 "2025-09-12T01:36:38Z")

</div>

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.
