# Wave enabled pipelines hit container pull limit

**URL:** <https://community.seqera.io/t/wave-enabled-pipelines-hit-container-pull-limit/2379>\
**Category:** Ask for help\
**Tags:** wave\
**Created:** [September 25, 2025, 12:47pm UTC](https://community.seqera.io/t/wave-enabled-pipelines-hit-container-pull-limit/2379 "2025-09-25T12:47:42Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sathiya\_Manivannan](https://dub1.discourse-cdn.com/flex013/user_avatar/community.seqera.io/sathiya_manivannan/32/2070_2.png) [@Sathiya\_Manivannan](https://community.seqera.io/u/Sathiya_Manivannan)\
**Post date:** [September 25, 2025, 12:47pm UTC](https://community.seqera.io/t/wave-enabled-pipelines-hit-container-pull-limit/2379/1 "2025-09-25T12:47:42Z")

</div>

Hi, I have a custom pipeline that I created with nf-core tools, that uses docker images which are pulled from a Docker hub repository. I have a pro Docker hub account and wish to use that while pulling these images.

I enabled wave in my pipeline’s config file like

```groovy
wave {
    enabled = false
}
tower {
   accessToken = “——————————————————————————————————”
} 

```

I have also saved my docker hub read-only access PAT that works for docker login in my Seqera account. The accessToken is added as above from the Seqera portal. There is no workspace name as it is a private Seqera account.

But I am getting a docker pull limit error when I run this pipeline for more than 60 samples within 6 hours.

```txt
Caused by:
Task failed to start - CannotPullImageManifestError: Error response from daemon: toomanyrequests: You have reached your unauthenticated pull rate limit. 
https://www.docker.com/increase-rate-limit

```

Is there any other piece of information I need to provide to the pipeline in order to login to the [docker.io](http://docker.io) to provide Dockerhub pro-account access to the pipelines?

---

<div class="post-metadata">

**Author:** ![FlorianWuennemann](https://dub1.discourse-cdn.com/flex013/user_avatar/community.seqera.io/florianwuennemann/32/638_2.png) [@FlorianWuennemann](https://community.seqera.io/u/FlorianWuennemann)\
**Post date:** [September 25, 2025, 1:00pm UTC](https://community.seqera.io/t/wave-enabled-pipelines-hit-container-pull-limit/2379/2 "2025-09-25T13:00:05Z")

</div>

Hi @Sathiya_Manivannan ,

One quick question to double check. In your code block above, you wrote `enabled = false` for wave. Was that a typo or is this what you actually have set in your configuration. For Wave to be active and use the Dockerhub PAT that you added to Seqera, you need to activate Wave with `enabled = true`. Just want to make sure this is set correctly before potentially diving deeper.

> **[Wave containers — Nextflow v25.04.7 documentation](https://www.nextflow.io/docs/stable/wave.html)**

Best,

Florian
