Show_analysis_paths doesn't work

Hi there,

I’m new to multiqc and trying to incorporate few things. I’m interested to disable analysis folder path in the reports.

My config.yaml looks like:

 - show_analysis_paths: False

The indentation is/are space-separated.
When I run multiqc with the config file I still see the paths at the top/header of the html file.

I run it as:

multiqc primary/fastp/tumor/ star_align/ fastp/tumor/ fastp/normal/ --zip-data-dir  --config config_multiqc.yaml --force

Thank you for creating this forum.
config_multiqc.yaml (49 Bytes)

I cannot upload the .html file so I’ve renamed it to .txt extension.
multiqc_report.txt (4.4 MB)

Please see attached screenshot.

multiqc version: v1.21

Hi @complexgenome,

The show_analysis_paths option should be top level, not part of report_header_info:

show_analysis_paths: False

MultiQC is actually doing what you asked it to, which is showing a header info block at the top saying “show_analysis_paths: False” - though probably not what you wanted :sweat_smile:

Hope that helps, please shout if you found some documentation etc. somewhere that makes it look like it should be part of report_header_info.


@ewels thank you.

I found on the page it says:

If you wish, you can disable the analysis paths and/or time in the report header with the following config parameters:

Thank you

1 Like