Hello. I am using the command line argument --conda.useMamba=true, but my log says Nextflow is still using conda (output below) and fails because it can’t solve the environment. I’m trying this out because outside of Nextflow, mamba is able to solve my env but conda cannot. Am I using the parameter correctly? Or perhaps there is another configuration parameter I missed? I’m using Nextflow version 21.10.6. Thanks!

Creating env using conda: test.yml [cache ...
Failed to create Conda environment
command: conda env create --prefix ...

Hi @irisdianauy. Welcome to the Seqera Community Forum! :wink:

Command line arguments starting with a double dash, --, are pipeline-specific arguments, not Nextflow arguments. For Nextflow arguments, use a single dash.

This should go in configuration files, though, such as nextflow.config, for example

conda.useMamba = true

or inside the conda scope you’re already using over there, for example:

conda {
  enabled = true
  useMamba = true

You can also set conda to use mamba as solver by default. Check this post in the forum for more info on how to do that. It’s much easier with conda.useMamba = true, of course, but maybe you want Mamba for other purposes too :wink:

Thank you so much for answering my question and adding more info! This solved my problem.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.