Unable to create Azure Batch Compute Environment

Hello! I am trying to setup a new Azure batch compute environment under my company workspace in Seqera Platform, but I am running into an Unexpected error. This error happens when I am trying to add Batch Forge.

The error is the following:
Unexpected error while processing request- Error ID: 4TuYEeuqCGw14GJBXT89ab

If I try with manual Azure Batch, there are no pools showing up to select from, while I have some pools activated at my Azure Batch service.

Do you have any ideas why this is happening? Thank you!

Hi @landroutsosAIE!

It sounds like Seqera Platform isn’t able to reach the Azure account, either because of networking or it can’t authenticate.

Do you have valid credentials added in Seqera Platform?

Are you able to see the data in the data explorer?

Can you share details of the Azure Batch account?

Hello @Adam_Talbot.

Thank you for your answer. We solved the problem this morning. We just had to manually type the region of our resources. Everything works now!

1 Like