Gitlab token not working when MFA is enabled

Hi, since I’ve enabled MFA in gitlab (mandatory), my gitlab tokens are not working anymore (authentication failure when pulling the repository).

I’m wondering if seqera patform is uing username + password instead of token for pulling the repo. Actually I’m not sure why we need to enter the password at all.

Any clue on how to solve it (disabling MFA is not an option for security reasons: Ransomware Attacks on GitHub, Bitbucket, and GitLab - What You Should Know - Blog |

Hi @arnaudceol,

Having the the password field also be mandatory could be a front-end bug, we’ll look into it - thanks for flagging!

That said, I’d expect the password to simply be ignored if the PAT is present and valid. We just gave this a spin (with 2FA enabled in GitLab) and it worked fine.

Are you still having problems? Could it be that enabling MFA invalidated your PATs or something? Does it still not work with a new PAT?


I did some tests again and it works… not sure at what point it failed before, maybe some invalidated token as you mentioned. Thanks!

That’s great - thanks for letting us know!