Nextflow - bash: /usr/local/bin/nextflow: Permission denied

I’m having an error when running nextflow on the command line. I did a “pull request” to update the human variation workflow a few days ago (wf-human-variation 23.10 from 23.04). It updated successfully and I ran the --help command that day. It looked like the installation went well. However, a few days later, when I tried to start a sample run it threw up the “permission denied error”.

bash: /usr/local/bin/nextflow: Permission denied

The actual nextflow folder has a red circle with a white x on it. Now when I try to run nextflow -help or -version, it throws up the same error. Is there a way to override this permission issue permanently?

Details of the system I am using: Ubuntu 20.04.6 LTS, Memory: 64 GB, gNOME 3.36.8, Processor Intel Xeon Gold (R) 5220R CPU @2.20 GHz x 48, Disk capacity 8.1 TB

I do not have much experience in bash/ troubleshooting nextflow. I have only recently started data analysis on command line. Any help will be highly appreciated! Thank you in advance.

Edit: The nextflow command that was given was the following:

nextflow run -bg epi2me-labs/wf-human-variation --snp --bam /mnt/d/G28.bam --bed /mnt/c/xyz.bed --ref /mnt/c/xyz.fa --basecaller_cfg 'dna_r10.4.1_e8.2_400bps_hac@v4.0.0' --sample_name G28 --out_dir /mnt/d/G28


This error message is to do with the file permissions of the Nextflow binary. You need to change the file permissions to allow execution.

You can find a tutorial on how to do this in Linux here:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.