File is not being staged into work directory

I’ve been attempting to run the rnasplice pipeline on four samples. The pipeline runs without issue when using GRCh37, however, when I run it against GRCh38, I experience a staging issue with one sample and one sample only.
.nextflow.log (73.5 KB)

I keep getting the error 137 for the samtools sort step, and when I navigate to the work directory for the samtools sort, the BAM file has not been staged in the directory. The aligned bam files both exist in the alignment directory, and they are of the appropriate size. I’ve attempted to run the pipeline from genome_bam and the staging error still occurs for that one sample. I’m attempting to run the pipeline from the transcriptome_bam, but would really like the rmats output for downstream analysis.

TL/DR; Running rnasplice using GRCh37 on data works. Running using GRCh38 results in staging error on the same sample at the same step running the pipeline from fastqs and BAMs.

Edit: Running from transcriptome_bam also resulted in staging failure, however, with a different sample file this time.

The 137 exit status is usually related to not enough memory issues. Different samples/references may require larger memory to run, which could explain what you’re running into. Have you tried running this in a compute environment with more memory available (and updating the memory process directive)?

Yes, that was my first attempt at fixing the issue. Sorry for not adding that to the original post. When running it, even with increased memory allocations, the job dies instantly. I would have expected if memory was an issue, the job would run until OOM actually occurred.