MultiQC: ModuleNotFoundError: No module named 'imp'

I am running fastqc and multiqc in ubuntu linux terminal. fastqc runs perfectly without any issues but multiqc fails to run, showing the message. No idea how to fix the missing ‘imp’ module. I tried to read and apply every solution found in the internet or google.

I used the command ‘conda install multiqc’ to install multiqc in the existing conda environment. I tried to install it in a new conda environment. Still, its showing the same message.The python version currently running is 3.12.0

Could anyone help to fix the issue?

Ooh, that’s not good. I managed to replicate it locally so it’s not just you. I guess you’re one of the first to try running with Python 3.12 - seems specific to this version of Python.

I made an issue on the MultiQC repo to track this:

Thank you so much ewels for the reply. You are absolutely right. It has some issue with the python 3.12. I fixed the issue with the installation of phython 3.11. Now, MultiQC is working.

Great stuff. Thanks for letting us know! We have a fix in the works. Hoping to release on Monday.

MultiQC v1.17 went out a few days ago and fixed the Python 3.12 problems, so for anyone landing here I’d recommend upgrading to both the latest stable releases of MultiQC + Python :heart:

You can find the release notes here:

1 Like