Nextflow run does not pick up parameters submitted via Seqera platform

My organisation runs nf-core and in house pipelines using the Seqera platform - and have been doing this successfully for some time using Azure.

Running a pipeline which has been successful in the past I am getting a minimal error on the platform which in the past has been caused by something like a parameter validation error. -

The workflow execution failed to start. Exit status: 1

When I access the batch pool and observe the node logs, however, it looks like the nextflow run is not picking up any of the parameters I have submitted via the Seqera platform. This results in a default set being run and a parameter validation error:

Jul-03 10:11:08.935 [main] DEBUG nextflow.Session - Session aborted -- Cause: e[0;31mThe following invalid input values have been detected:

* Missing required parameter: --input
* Missing required parameter: --outdir

I have tried inputing the parameter values myself, and uploading a json from previously successful runs - but both cause the same error. I have tried a number of different compute environments which were all working last week.

Any help with this would be great.

Hi Ben,

Thanks for reporting this issue. The Platform engineering team looked into it and pushed a fix that is now live in
You should be able to run pipelines without issues now.

Brilliant - thanks for the quick fix.

1 Like